PDA

View Full Version : mamba motor jammed / help



dirtdynamics
01-24-2006, 03:00 AM
I had a mamba 25 set up with a mamba motor (6800kv i think.)
played it with 3 cell lipo and it was fast.
took it home, cleaned it and a few weeks later i tried it again but the motor was real jerky.
and it got really hot real fast
that it melted the plactic protector on my work table.
I removed the motor and it seem to spin fine till 3/4 along the way
felt jammed but could still spin through if i force it.
any idea what happened and what i can do?
Anybody had that happen to them?
please help me.
Thanks

mOOsE
01-24-2006, 04:00 AM
sounds like the armature (rotating part) became unlgued from the magnets. The jerking part was cogging, which causes tons of heat very fast. I would contact castle to see if they will honor any sort of warranty the motor may be under. Otherwise you know have your excuse to buy an AON4900 or Hyperion 6k ;)

dirtdynamics
01-24-2006, 09:13 AM
sounds like the armature (rotating part) became unlgued from the magnets. The jerking part was cogging, which causes tons of heat very fast. I would contact castle to see if they will honor any sort of warranty the motor may be under. Otherwise you know have your excuse to buy an AON4900 or Hyperion 6k ;)

Hmmmmmmmm, thats what another local guy said...
in fact i'll be mailing it back to them since its of no use to me now.
Hopefully its covered under some kinda warranty they have and maybe they'll give me some kinda free motor back... :D

As for the new AON or Hyperion... I'm on the way to getting another inferno complete with either of these motors... :cool:

Thanks for the reply.